Two '09 SE5s won't start - Spyder TechTalk - can-am Spyder Forums - SpyderTalk.com

Jump to content







Photo

Two '09 SE5s won't start


  • Please log in to reply
1 reply to this topic

#1 kravnh

kravnh

    Newbie

  • Members
  • 1 posts
  • Gender:Male
  • Location:Stratham, NH
  • Your Ride:Considering a Spyder

Posted 18 April 2019 - 02:18 PM

Hi everyone, I have two 2009 SE5s that have not been ridden more than a couple times per year for the last five or six years. Due to reasons beyond my control, they have been sitting in the garage for approximately 9 months, on trickle chargers and with Sta-Bil in the fuel tanks. Historically, I have always fired them up every month or so, but not this time. Yesterday, I finally had the opportunity to get to them, and found that both batteries were dead. I purchased new batteries, but neither bike will start. They both crank, but will not turn over. The fuel tanks are close to full, and the gas does not smell fouled.

 

I don't know where to begin trying to solve this problem. I am not particularly mechanically inclined, so if anyone has any advice for me, please pretend you're explaining to a 5 year old (not proud). 

 

Thanks in advance for any help!

 

Keith



#2 Easy Rider

Easy Rider

    Member

  • Members
  • 20 posts
  • Gender:Male
  • Your Ride:'17 RTL

Posted 20 April 2019 - 03:05 PM

have not been ridden more than a couple times per year for the last five or six years.

 

The fuel tanks are close to full, and the gas does not smell fouled.

Regardless of how it looks or smells, 5 year old fuel HAS caused some damage most likely.

 

Given  your admitted lack of skill, I think you need help from a shop......including towing.

 

AND after they are running again, you need to SELL them so somebody can get some use and enjoyment out of them.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users