Jump to content

 





 
 
 

Photo

Handlebar Freeplay


  • Please log in to reply
6 replies to this topic

#1 danceblade

danceblade

    Member

  • Members
  • 11 posts
  • Your Ride:Spyder

Posted 23 September 2008 - 02:25 PM

Recently my Spyder developed about 1/2 inch of freeplay in the handlebars. That is, they could be moved left or right about a half inch before the wheels would actually turn. The dealer is trying to discover the cause but has not located the problem. Has anyone else experienced this issue. And if so, discovered the cause/adjustment or repair?
I do have the one inch riser installed but the dealer said that was not the cause. The bike has 2400 miles at this point.

Update-Yesterday the technician called and told me the splines on the handlebar steering shaft have "rounded" over. BRP is providing a replacement. Cause of the "rounding" not known but it does suggest that the shaft may not have properly heat treated.

Edited by danceblade, 25 September 2008 - 02:00 PM.


#2 DragonSpyder

DragonSpyder

    Advanced Member

  • Members
  • 132 posts
  • Location:Livonia, NY
  • Interests:Sports, Quads, Now 3-Wheeling
  • Your Ride:SM5

Posted 24 September 2008 - 08:40 AM

Check tie-rod ends.

#3 Saluda

Saluda

    Advanced Member

  • Members
  • 409 posts
  • Gender:Male
  • Location:MA
  • Interests:Snowmobiling, kayaking, motorcycles and pedal biking.
  • Your Ride:2013 STS

Posted 24 September 2008 - 01:43 PM

No problem here, have less miles than you.

Edited by Saluda, 24 September 2008 - 01:44 PM.

Never stop questioning. (Happy Spyder owner)

#4 Everett

Everett

    Advanced Member

  • Members
  • 32 posts
  • Your Ride:'09 Spyder SE5

Posted 17 November 2008 - 06:51 PM

I only have 110 miles on my SE5, and yesterday noticed the same 1/2 inch freeplay. It appears to be located in the handlebar onit, like the bolts in the bar clamp are loose----going to check it out......Ev

#5 owner 573

owner 573

    Newbie

  • Members
  • 7 posts
  • Gender:Male
  • Location:East Bay Area
  • Your Ride:Spyder #573

Posted 24 November 2008 - 07:51 PM

I have the same play and the dealer did not know the cause during the 3000 mile check. They advised that it is not a known concern but something that they will look into.

#6 Ken5517

Ken5517

    Ken5517 / Wish Again

  • SPYDER NATION
  • 1,434 posts
  • Gender:Male
  • Location:San Diego Ca. (El Cajon)
  • Your Ride:2008 GS Spyder & 2010 RTS Spyder

Posted 24 November 2008 - 08:37 PM

OK guys

I had the 1" riser installed a year ago and had that same 1/2 play and when FBC checked it out the nut had to be re tightened no other issues.

there should be no play in the steering
"Spyder Ryder of America" is on Face Book now - join a chapter today

Contact Ken to start your local SRA Chapter today, expanding across America.

#7 jrk36

jrk36

    Newbie

  • Members
  • 1 posts
  • Your Ride:Spyder RS

Posted 01 October 2016 - 09:35 PM

This is a very old post, but there doesn't seem to be any conclusions.

My 2008 RS SM5 with 17,000km on the clock developed this free play at the handlebar ends about 1,500km ago. There is no play in the tie-rod ends or looseness in the ball joints. It doesn't seem to be getting worse.

 

Has anyone had this and its been fixed? If so what was the problem?

What do I need to strip down to get to the steering?

Any pointers would be appreciated.

 

Thank you,

John Kennedy






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users